Home My Page Projects MPTK: The Matching Pursuit ToolKit
Summary Activity Forums Tracker Lists Docs News SCM Files

Forum: help

Monitor Forum | Start New Thread Start New Thread
RE: Anywave Dictionary [ Reply ]
By: Sasho Musevic on 2009-04-17 15:28
I got the same error when I used dictionary definition generated with matlab utility dictwrite.m with MPTK 0.5.5. The generated dictionary definition version was 0.4beta.

Hope it helps,

RE: Anywave Dictionary [ Reply ]
By: RĂ©mi Gribonval on 2009-01-26 09:24
It would help to have more debugging information, which can be obtained by recompiling MPTK with the BUILD_DEBUG option on. As said in my answer to your previous post, this might also be solved in the upcoming release, but you will need to check.
Anyway thanks for this feedback since it is important to have the anywave feature working properly ...

Best regards,


Anywave Dictionary [ Reply ]
By: Corey Kereliuk on 2009-01-25 23:59
I have MPTK compiled and working with the default dictionary. But it does not work with the wavetable dictionary provided with the installation. Here is my command line + output:

mptk INFO -- mpd - ------------------------------------
mptk INFO -- mpd - ------------------------------------
mptk INFO -- mpd - The command line was:
mpd -v -D ./wavetable/defaultWaveTable.xml -n10 ./signal/glockenspiel.wav test.bin
mptk INFO -- mpd - End command line.
mptk INFO -- mpd - Loading the dictionary...
mptk INFO -- mpd - (In the following, spurious output of dictionary pieces would be a symptom of parsing errors.)
Bus error

I have also tried making my own binary dictionary, and that gives the same error.

Any help would be much appreciated. For now I will have to use my own (slow) implementation of MP since I am using a non-standard dictionary.


Corey Kereliuk