Home My Page Projects MPTK: The Matching Pursuit ToolKit
Summary Activity Forums Tracker Lists Docs News SCM Files

Forum: help

Monitor Forum | Start New Thread Start New Thread
MPTK 0.5.6 mex files libfftw issues [ Reply ]
By: Bertrand Scherrer on 2008-11-28 19:40
Dear MPTK team,

I have built and installed MPTK-0.5.6 on a Mac OS X (10.4.11) machine, following the instructions in the BUILD_MPTK_for_LINUX_OSX.pdf document.

I updated my libraries: fftw (3.2), libsndfile (1.0.17). Then I activated the BUILD_MATLAB_MEX_FILES option in ccmake and then ran make and make install.

I can find the mex files in /usr/local/matlab/ so the mex compilation seems to have worked.

After adding /usr/local/matlab to the path in Matlab I ran the GettingStarted script. I got the following error when the getmptkinfo function was called:

??? Invalid MEX-file '/usr/local/matlab/getmptkinfo.mexmac': dlopen(/usr/local/matlab/getmptkinfo.mexmac, 1): Library not
loaded: /opt/local/lib/libfftw3.3.dylib
Referenced from: /private/Network/Servers/borges.mt.lan/Volumes/home/scherrer/lib/libmptk.dylib
Reason: Incompatible library version: libmptk.dylib requires version 6.0.0 or later, but libfftw3.3.dylib provides
version 5.0.0.

Error in ==> GettingStarted at 110
mptkInfo = getmptkinfo;

It might be a silly question but I am getting a little mixed up with the version numbers that are shown in this error message.

In other words, which library does the version 6.0.0 refer to exactly ?

Thank you for your help,